Dexcom G6 Sensor Failures

I am using the Dexcom G6 and since August I have not had one sensor last the full 10 days. I started to log the behavior and here is what I’ve found. On day 7 the sensor goes into an error state for a couple of hours and then bounces back. At this time I have to calibrate since the readings are +/- 30 points off. On day 8 with a couple of calibrations, I can get through the day ok. By day 9 my readings look like an EKG line and the sensor is in and out of error state. By this time I have to change the sensor.

Before August I rarely had a failed sensor. In fact, the G6 was so accurate I hated to replace the sensor on day 10. To me, it’s obvious that Dexcom has made some change that causes this issue. For the past several months I’ve seen the exact same behavior and failure pattern with every sensor. Each time on day 8 I call Dexcom and they send me a replacement sensor, with no questions asked.

Is anyone else seeing more G6 sensor failures as of late? I’m debating if I should go back to the Libre or try Eversense.

Cheers,

I have 2 kids on the G6 since it was released last year. I have had various times where it hasn’t lasted 10 days, but have not noticed any change in the past 6 months. In fact, I just changed one recently after the 10 days.

If you are having issues, maybe you need to try different sites?

Interestingly, I use the Libre and have been having the same issue. I had three or four sensors that were remarkably accurate for the most part, and the last few have been WAY off. I have called the company and they have replaced them, but I do have to answer their questions for about 20 minutes. The one I am using currently (and this is the first time this has happened), the sensor was off 30-35 points for the first five days and is now very accurate. It can be really frustrating… sometimes I think I of going back to Dexcom but when I tried them about a year ago they were not as accurate as the libre for me. Plus it bugs me that the Dexcom is so much more expensive, even though my insurance pays for most of it. It just seems wrong. I think the libre is about $200 per sensor and the Dexcom closer to $600? Can anyone confirm that?

A one month supply, 3 sensors for Dexcom costs $350 retail.

I used to use the Dexcom G6 but hated it. It never lasted and made my skin puffy. I switched to the 670G which works great for me. I would highly recommend switching if you are able to.

My daughter has been using Dex g6 since it came out. Very few problems. The time she did get a lot of sensor errors I noticed that the sensor wire was bent when I pulled it out. Make sure you are placing it in a fatty area and not muscle

1 Like

I’m still new to the dexcom on my 7 year old. I inserted one yesterday and before the warm up was complete it told be sensor failure. Today I just inserted a new one and it’s immediately telling me there’s an error. What am I doing wrong?

35 minutes inserted and it’s failed.

Could be a bad lot#, it happens, if you have different #'S try using that also call customer service.

Brad you’re awesome you’ve answered both questions I’ve had so far. I’m getting so frustrated I feel like the dexcom is more trouble than it’s worth but I’ve been assured it’s well worth it in the end.

It is, just remember technology always has its issues, but saving 15 finger pricks a day is well worth it and being able to watch over there#s if there to young to control

1 Like

Megan @Lucamom, sad to think this way, but it might be that your daughter’s body is not “compatible with” the G6. I’ve used both G5 and G6 and never had a “failure” or had one fall off.

I hope that you have called Dexcom support and explained exactly what is happening and requested assistance. You should also request a meeting with a Dexcom Representative to be with you when beginning a new sensor session.

I did call Dexcom support and it was a great experience (a terrible wait) and they’re mailing me 2 replacements.

1 Like

Anytime the G6 lasts less than the advertised 10 days, I call Dexcom and they send out a new sensor. Sometimes you can get bad lots but it is definitely getting better each month. At least they stand behind their product.

I’ve been using my G6 for a year and every batch of 6 sensors I have about 2 replaced, mostly for the placement hitting a capillary causing blood. The rep told me the sensors are designed like this knowing that there is a high rate of sensor failure due to the need for sensitivity for it to technically read each body. This is why they just ask you the questions to document the case then send replacements. It’s annoying but now I have learned where and how gentle to inject on the site on my stomach. One time I was close within a week from changing the transmitter and they instructed me to switch it out early to stop the monitor from hanging on calibration. They replaced my transmitter for that as well. The rep told me it’s rare to have a bad monitor and normal to have a sensor go bad due to too much blood on injection. Hope sharing my experience helps and you get it figured out. I can’t live without it has saved my life several times.

1 Like

I have been having similar results of good performance for the first week followed by sporadic outages and then a final shutdown after 8 or 9 days.

Over the summer I had a bad run of sensors and has a few that died during warm up. then things were good til about a month ago. Over the last month or so the problems have returned. I just had one die in warmup on 1/1 and am now without til 1/3 since they haven’t lasted long enough to get my next prescriptions.

It is frustrating and wish they could get his straightened out. I too am considering switching back to Libre even though due to insurance, it will cost a lot more.

Reading all these posts, I would surmise a drastic change in the manufacturing process, resulting in a serious drop in quality of the sensors. I am still using G5 and recently–past several months–a loss of signal alarm and have to wait up to two hours to get a signal back.

I am also on the new receiver (which is total junk, btw). I doubt it’s the receiver itself, though it could be. I think, with what you all said, they changed the whole process. I suspect they farmed the manufacturing to a foreign country and can’t control the quality. One thing to do that will have an effect if enough of us do it, is to report a function issue with the FDA thru its MAUDE program. Go here to file and be as specific as you can.

https://www.accessdata.fda.gov/scripts/medwatch/index.cfm?action=consumer.reporting1

1 Like

Boy, Davy, your recent experience with the G5 sure rang a bell with me! I’m still on the G5 too, and it used to be great until recently. There are days when that annoying ??? symbol on the receiver goes on and off all day and I finally just give up and change it. Then there are times when the difference bet the dex and my BG meter reading is anywhere from 50 to more than 100 points! And the stories from other T1’s about the G6 aren’t convincing me that it’s any better.

I think you’re right about Dexcom farming out its manufacturing to a foreign country without proper quality control. After all, they’re clearly farming out their tech people to foreign countries, and while they try to be helpful, they mostly succeed in reading me the manual.

Thanks for the FDA info. We should all complain.

1 Like

CleverRuth, I have been using the G6 since March 5. When I used it on my arm the receiver would lose signal many times and several sensor changes had lots of blood so had to change right away. I started on the Tandem tslim pump in July and sensor in my belly and now seldom have lost signal. I think the pump is much better than the receiver for signal loss. When I have signal loss I hold the pump over the sensor for 10 minutes and regain signal. Another hint, when you take off a sensor wait 15 minutes before inserting a new one. Once sensor and transmitter are on, wait 5 minutes before putting in the code and doing Start Sensor. I think my failures in the past were because I was rushing and not waiting as instructed. I use a timer for these wait periods. I have had a small amount of bleeding when a sensor was inserted but continued with inserting the transmitter and had accurate readings the entire 10 days. Since starting the Tandem tslim pump as the reader I have had no failures. My few prior sensor failures were when I was using the receiver.

1 Like

I used the Medtronic Guardian 3 sensors for 18 months and switched to Dexcom G5 4 months ago. What a difference! Dexcom is so easy to insert and start up and sets off far fewer alarms. I don’t use the receiver, just my iPhone and Apple Watch so I can see my BS at the flick of my wrist. Only down side is it does not communicate with my Medtonic 670 G pump so I have to do several manual adjustments throughout the day. Have to wait another 18 months before Medicare will cover a new pump🙁.
With both brands I have found very high accuracy with insertion in my upper thigh areas. Never falls off and doesn’t get bumped or hung up on clothing. I highly recommend giving your thighs a try.:wink: