Problem with all tandem infusion sets


I have been using tandem infusion set for about a year now . I use autosoft 90 . But recently in the past week , it seems like the insulin from the pump isn’t working on me . I tried tru steel infusion set thinking it might be an issue with autosoft 90. It gave me occlusion error on the pump after 20 mins of insertion. Tried it with another one later and same issue occurred after 30mins.

Later I tried Autosoft 30, seemed like it was working for sometime (1hr) but the glucose kept going high. At night, it went up to 16 and bolus did not work. So had to use novo rapid pen.

Seems like none of the infusion sets of tandem are working on me . Has anyone faced similar issue with tandem pump . The past week has been really frustrating.


Hi @pridiabetic890 and welcome to the forum. A while back I had some problems with my Autosoft30 infusion sets (my overall favorite) which I’ve used for a very long time - I kept going high after insertion and couldn’t figure out why. One day I forced myself to slow down and review my process step by step: I found I was tipping it at a little bit of an angle rather than holding the base flat so it would insert at 30 degrees; as a result there was a bend in the cannula. Not sure why I did that but once I stopped it worked again. Also do you check for air bubbles? I know I get so used to doing things by habit, sometimes I get careless and skip something, or go too fast.
I don’t know if that helps - if not I do hope you find what you’re looking for.

Hi, Priyanka @pridiabetic890, and unfortunately, yes. After consulting with multiple endos, CDEs, Tandem reps, and other users, and diligently following every suggestion anyone could think of for far too long, we finally gave up on the tslim and went back to Omnipod, which works well for us. We never did figure out why, but my daughter just never had success with any of the infusion sets Tandem makes, and we tried them all.

Not wishing it on you, but if that’s you, too, at least you’re not alone.