"Pump not primed" long after a site change

I have an Animas Ping and have been getting "pump not primed-no delivery" for awhile a day or two after I changed my site.  It just happened again after changing my site yesterday afternoon.  I just prime it (pretend to fill my cannula) and it's good again, but I don't like when my pump starts blasting Beethoven (is it Beethoven?) when I'm in class.


Does this happen to others?  Is it because of an error I am making?  Or could my pump have some kind of defect?



Hi Courtney,

I think I recall C having the same issue a while back, and eventually Animas replaced her pump because of it.  I'd give Animas a call.

Good luck!


Yes, I did have the same issue. At first Animas kept telling me it was a "user error". So I started calling them EVERY time it happened. Eventually, after the 4th phone call in just a few days and a couple middle-of-the-night calls, they realized it wasn't anything I was doing and replaced it. They obviously don't want to have to send out a new pump, but if you badger them enough, they'll do it. I also mailed them all the cartridges I had been using when I got the error message. (They got 7 cartridges in just a couple weeks)

That has been happening to me as well! I'm glad i'm not the only one, although I have not done anything about it cause it just stopped giving me the message now...

I'm glad I'm not the only one too.  I'm not fed up enough yet... but I will be sure to call them next time.  That Beethoven song really gets me...

you know you can change the tones...you can even make your own tone!

How do you make your own tone?

there's an application on EZ Manager to create your own tones. you have to know how to read music and play piano, which i do, but still found it horribly confusing. 

but that's probably just because i'm computer deficient....

I just pushed random 20 keys until I thought it sounded cool haha

I would periodically get the pump not primed error as well. Normally though once I changed my site it would go away. Sometimes it truly is user error and the infusion set not being in the right area. Granted it has only happened like three times. I know you said you changed your site too. You may want to try an area that has rarely seen pump action. There is a tiny, tiny chance you could be hitting scar tissue or something which could be affecting your pump.

However, I tend to believe once/twice is user error. Thrice is just bad luck. There is no rhyming word for four. So I am going with Fice, it's the darn pump. Just call and politely see what they suggest. Each time they tell you to do something you have already done ask if it could be something else, as you have tried this step already.

Just make sure you get the name of who you talk to as well, that way if you have to call back again you can say, I was talking to ... and we tried that already on the 22nd. The more you are ready for them, the easier it is for you.

Dang it, Brian, I should have gotten her name.  If only I read your comment 5 minutes earlier...

I just had a very good experience with the Animas customer service though.  She talked about the possible reasons, was very understanding that it doesn't seem like user error, but her guess is that I have a box of bad cartridges or something is wrong with the pump.  She said if I give it a couple more weeks of trying different cartridges from different boxes and it still happens, then they will look into a replacement pump.  

:D My first time calling them.  I am so glad it went well!

Haha. Sorry. well it was a productive call to say the least. Maybe she will have solved your issue. If it is carts?? will they replace those??